Router on a stick

“Router on a stick” è il nome che si dà ad un router che ha il compito di effettuare routing tra vlan diverse usando un’interfaccia in trunk su cui avviene il traffico delle vlan interessate.

In sostanza è una maniera per far comunicare vlan differenti; il traffico tra le diverse vlan potrebbe avvenire anche connettendo le diverse interfacce del router a diverse porte dello switch su vlan diverse, ma il sistema non è pratico, scala male ed è costoso.

Per questa ragione si ricorre ad una configurazione in trunk. Nell’esempio abbiamo due vlan, la 100 e l a200, che comunicano tra di loro attraverso il router, come si può vedere effettuando un ping da uno dei due pc.

esempio di router on a stick

esempio di router on a stick

La configurazione è veramente minimale, ma dà un’idea di come si affronta il problema. Di seguito la configurazione del router. Il comando ip nat inside non serve in questo caso, ma dovrebbe dare un’dea di come proseguire nel caso che il router debba fare traffico verso  internet. Non dimentichiamo di dare un “no shut” all’interfaccia (giga0/0 in questo caso) o le sottointerfacce non si avvieranno.

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0
ip nat inside
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 200
ip address 192.168.200.1 255.255.255.0
ip nat inside

Il file packet tracer incluso consente di vedere “in vivo” il funzionamento e contiene tutte le configurazioni (di router e switch). Buon divertimento e alla prossima.

router on a stick

Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. Usiamo i cookies per ragioni tecniche. Teniamo in alta considerazione la tua privacy.

Questo sito utilizza i cookie per fonire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o clicchi su "Accetta" permetti al loro utilizzo.

Chiudi